Elevated terminal creation failures on Android SoftPOS
Resolved
Jun 29, 2026 at 1:51pm UTC
This incident is now resolved; the reported increase in terminal creation failures was traced to a device-level configuration setting on a small number of devices rather than a service issue. Card-present transactions on existing terminals were not impacted, and no further action is required.
Affected services
Updated
Jun 29, 2026 at 1:45pm UTC
We are continuing to investigate an increase in terminal creation failures affecting certain SoftPOS deployments on Android, and there is no change to report at this time. Card-present transactions on existing terminals are not expected to be impacted, and we will share a further update as soon as we have more information.
Affected services
Created
Jun 29, 2026 at 1:26pm UTC
We are currently investigating an increase in terminal creation failures affecting certain SoftPOS deployments on Android. Card-present transactions on existing terminals are not expected to be impacted, and we will share an update as soon as we have more information.
Affected services