Back to overview
Resolved

Elevated card-present transaction declines

Jun 26, 2026 at 9:05am UTC
Affected services
Transaction Processing & API

Resolved
Jun 26, 2026 at 1:00pm UTC

This incident can be marked as resolved, with no issues for the last couple of hours. We will continue to monitor closely and apologise for any inconvenience caused.

Updated
Jun 26, 2026 at 9:51am UTC

We are continuing to investigate occasional declines affecting some card-present transactions. We keep it under observation

Updated
Jun 26, 2026 at 9:18am UTC

This incident has been resolved. An elevated decline rate previously affected some card-present transactions on certain terminals, with some transaction categories more affected than others, and all affected payments are now processing normally. We will continue to monitor closely and apologise for any inconvenience caused.

Updated
Jun 26, 2026 at 9:13am UTC

We have identified the cause of an elevated decline rate affecting some card-present transactions on certain terminals, with some transaction categories more affected than others. Many payments continue to process normally, and we are working to resolve the issue. A further update will follow shortly.

Created
Jun 26, 2026 at 9:05am UTC

We are currently investigating reports of an elevated decline rate affecting some card-present transactions on certain terminals. Many payments continue to process normally, and we are working to identify the cause. A further update will follow shortly.