Payment failures on non-PRO devices
Resolved
Jun 24, 2026 at 11:07am UTC
Payments are going through without increased failure rates. We are monitoring closely to confirm full recovery.
Affected services
Updated
Jun 24, 2026 at 10:39am UTC
The platform has been stabilizing, and we see a decrease in the failure rates. We are continue to monitor the situation
Affected services
Updated
Jun 24, 2026 at 10:30am UTC
Currently affected are merchants using non-Pro devices, including SurfTouch, SurfPrint and SurfPad
Affected services
Created
Jun 24, 2026 at 10:28am UTC
We are seeing an increase in failure rates affecting payments. We will share more as soon as we have it.
Affected services