Back to overview
Resolved
Investigating GSM connectivity
Jun 24, 2026 at 9:52am UTC
Affected services
GSM
Resolved
Jun 24, 2026 at 11:52am UTC
The provider has resolved this incident. Thank you for your patience — please reach out to your Surfboard contact with any questions.
Affected services
Updated
Jun 24, 2026 at 10:43am UTC
The connectivity has recovered for a majority of the merchants and we are working together with the provider on a fix.
Affected services
Created
Jun 24, 2026 at 9:52am UTC
We are investigating reports of GSM connectivity not working affecting some terminals using this as their primary connectivity method. We will share more as soon as we have it.
Affected services