Back to overview
Resolved

Degraded performance in Transactions

Jun 18, 2026 at 4:00pm UTC
Affected services
Transaction Processing & API

Resolved
Jun 18, 2026 at 4:00pm UTC

We are currently experiencing degraded performance in transaction processing. Investigation is underway.